WEB技术论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: ASP asp.net php
查看: 908|回复: 0

易语言的JSON解析,本人常用的方法 分享出来了

  [复制链接]

534

主题

541

帖子

2044

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2044
QQ
发表于 2018-1-3 02:53:08 | 显示全部楼层 |阅读模式

需要引入精易3.7模块

BASIC
.版本 2
.支持库 spec

.子程序 获取直播列表
.参数 分类ID, 整数型
.参数 分页id, 整数型
.局部变量 列表, 文本型
.局部变量 i, 整数型
.局部变量 json, 类_json
.局部变量 sn, 文本型
.局部变量 聊天内容, 文本型


列表 = 到文本 (网页_访问 (“http://sortType=0&callback=jQuery” + 时间_取现行时间戳 () + “&page=” + 到文本 (分页id) + “&count=16&category=” + 到文本 (分类ID) + “&from=mpc_ipcam_web&_=” + 时间_取现行时间戳 () + “”, 0, , , , , , , ))
列表 = 文本_取出中间文本 (列表, “({”, “})”)
json.解析 (“{” + 列表 + “}”)
' 调试输出 (列表)
列表总数 = json.取属性 (“devices”).成员数 ()
.变量循环首 (1, json.取属性 (“devices”).成员数 (), 1, i)
    sn = 子文本替换 (json.取通用属性 (“devices[” + 到文本 (i - 1) + “].sn”), #引号, , , , 真)
    totalNum = 子文本替换 (json.取通用属性 (“totalNum”), #引号, , , , 真)
    延迟 (1)
    处理事件 ()

    ' 调试输出 (totalNum)
    组合框2.加入项目 (sn, 到整数 (sn))
.变量循环尾 ()
组合框2.现行选中项 = 0
爱仿站的中年人
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|码农集营 ( 粤ICP备15042209号-1 ) 深圳龙岗交友群

GMT+8, 2019-3-25 16:04 , Processed in 0.080391 second(s), 23 queries .

Powered by 码农集营 X3.4

快速回复 返回顶部 返回列表